横盘突破,低位缩量横盘突破选股公式

Q1:什么是长期横盘突破选股公式

REF(((HHV(HIGH,30)-LLV(LOW,30))/LLV(LOW,30)),1)<=(5/100)
&& CLOSE>=REF(HHV(HIGH,30),1) && BARSCOUNT(CLOSE)>30;

Q2:通达信编写指标,关于横盘突破的。

基础线:MA(C,5),LINETHICK3,COLOR00CCFF;
刚柔线:MA(C,13),CIRCLEDOT,COLORYELLOW;
生命线:MA(C,34),CIRCLEDOT,COLORMAGENTA;
MA05:=MA(C,5);
MA10:=MA(C,10);
MA20:=MA(C,20);
MA30:=MA(C,30);
五日乖离率:=(C-MA05)/MA05*100;
BB05:=ATAN((MA05/REF(MA05,1)-1)*100)*180/3.1416;
速度5:=SMA(EMA((MA05-REF(MA05,1))/REF(MA05,1),3)*100,3,1);
加速度5:=EMA((速度5-REF(速度5,1)),3),NODRAW;
IF(BB05>30 AND MA05>REF(MA05,1), MA05,DRAWNULL),LINETHICK3,COLORRED;
BB10:=ATAN((MA10/REF(MA10,1)-1)*100)*180/3.1416;
IF(BB05<0 AND MA05<REF(MA05,1), MA05,DRAWNULL),LINETHICK3,COLORGREEN;
三拾日乖离率:=(C-MA30)/MA30*100,NODRAW;
VAR1:=(MA20-MA30)>REF((MA20-MA30),1) AND MA20>REF(MA20,1) AND MA30>REF(MA30,1);
VAR2:=(MA30-MA20)<REF((MA30-MA20),1) AND MA20<REF(MA20,1) AND MA30<REF(MA30,1);
BB30:=ATAN((MA30/REF(MA30,1)-1)*100)*180/3.1416;
强势狙击:=FILTER(BB30>30 AND BB10>45 AND CROSS(BB05,60),10);
加仓:=FILTER(COUNT(CROSS(BB05,30),5)>=1 AND MA05>REF(MA05,1) AND 三拾日乖离率>REF(三拾日乖离率,1) AND MA10>REF(MA10,1)
AND 加速度5>REF(加速度5,1) AND 速度5>REF(速度5,1) ,10) ;
清仓:=FILTER(COUNT(CROSS(30,BB05),5)>=1 AND (C>MA30 OR O>MA30) AND MA05<REF(MA05,1) AND 三拾日乖离率<REF(三拾日乖离率,1) AND MA10<REF(MA10,1),10);
DRAWTEXT(加仓 ,LOW*0.98,'◆加二'),COLORYELLOW;
JC:=CROSS(0,五日乖离率) AND 三拾日乖离率<REF(三拾日乖离率,1) AND MA10>REF(MA10,1) ;
减仓:=FILTER(JC,10);
MR:=COUNT(CROSS(五日乖离率,0),3)>=1 AND 三拾日乖离率>REF(三拾日乖离率,1) AND MA05>REF(MA05,1) AND (C/REF(C,1)-1)*100>5 AND REF(C,1)<MA30;
买入:=FILTER(MR,10);
DRAWTEXT(减仓,HIGH*1.02,'◆风险'),COLORCYAN;
DRAWTEXT(买入,LOW*0.96,'◆买二'),COLORYELLOW;
DRAWTEXT(清仓 ,HIGH*1.00,'◆清仓'),COLORGREEN;
VAR21:=MAX(ABS(HIGH-AMOUNT/VOL/100),ABS(AMOUNT/VOL/100-LOW));
VAR3:=ABS((OPEN+CLOSE)/2-AMOUNT/VOL/100);
MV:=(VAR21+VAR3)/AMOUNT*VOL*100*50;
压力:MA(REF(HHV(C,30),1),2),COLOR9DFFFF;
支撑:MA(REF(LLV(C,30),1),2),COLORABFF46;
{彩色K线}
TYX3:=MA(REF(HHV((C+L+O+H)/4,30),1),3);
TYX4:=MA((C+L+O+H)/4,13);
TYX5:=EMA((C+L+O+H)/4,21);
{空心红}
STICKLINE(C<TYX5 AND C>O,H,L,0,0),COLORRED;
STICKLINE(C<TYX5 AND C>O,C,O,3,1),COLORRED;
{深绿}
STICKLINE(C<TYX5 AND C<O,H,L,0,0),COLOR007700;
STICKLINE(C<TYX5 AND C<O,C,O,3,0),COLOR005500;
STICKLINE(C<TYX5 AND C<O,C,O,2,0),COLOR006600;
STICKLINE(C<TYX5 AND C<O,C,O,1,0),COLOR007700;
{蓝}
STICKLINE(C>TYX5 AND C<O,H,L,0,0),COLORFFDD44;
STICKLINE(C>TYX5 AND C<O,C,O,3,0 ),COLORFF7700;
STICKLINE(C>TYX5 AND C<O,C,O,2,0 ),COLORFFAA22;
STICKLINE(C>TYX5 AND C<O,C,O,1 ,0 ),COLORFFDD44;
{黄}
STICKLINE(C>TYX5 AND C>O,H,L,0,0 ),COLOR00EEFF;
STICKLINE(C>TYX5 AND C>O,C,O,3,0 ),COLOR00AAFF;
STICKLINE(C>TYX5 AND C>O,C,O,2,0 ),COLOR00CCFF;
STICKLINE(C>TYX5 AND C>O,C,O,1,0 ),COLOR00EEFF;
{粉红}
STICKLINE(C>TYX4 AND C>O,H,L,0,0),COLORFF66AA;
STICKLINE(C>TYX4 AND C>O,C,O,3,0 ),COLORFF11FF;
STICKLINE(C>TYX4 AND C>O,C,O,2,0 ),COLORFF44FF;
STICKLINE(C>TYX4 AND C>O,C,O,1,0 ),COLORFF66FF;
{亮灰}
STICKLINE(C>TYX4 AND C<O,H,L,0,0),COLOR999999;
STICKLINE(C>TYX4 AND C<O,C,O,3,0),COLOR555555;
STICKLINE(C>TYX4 AND C<O,C,O,2,0),COLOR777777;
STICKLINE(C>TYX4 AND C<O,C,O,1,0),COLOR999999;
{深红}
STICKLINE(C>TYX3 AND C>O,H,L,0,0),COLOR0000DD;
STICKLINE(C>TYX3 AND C>O,C,O,3,0),COLOR000099;
STICKLINE(C>TYX3 AND C>O,C,O,2,0),COLOR0000BB;
STICKLINE(C>TYX3 AND C>O,C,O,1,0),COLOR0000DD;
{涨跌停K线}
STICKLINE(HIGH=LOW AND CLOSE=OPEN AND (CLOSE/REF(CLOSE,1))>1.048,HIGH,LOW,3,0) ,COLORRED;
STICKLINE(HIGH=LOW AND CLOSE=OPEN AND (REF(CLOSE,1)/CLOSE)>1.048,HIGH,LOW,3,0) ,COLOR00FF00;
{突破}
STICKLINE(REF(COUNT(C<TYX3,5)=5,1) AND C>TYX3 AND C>O,C,O,1,0),COLOR00CCFF;
{买卖主图}
MA18:=MA(CLOSE,18);
MTM:=C-REF(C,1);
DX:=100*EMA(EMA(MTM,6),6)/EMA(EMA(ABS(MTM),6),6);
买:=LLV(DX,2)=LLV(DX,7) AND COUNT(DX<0,2) AND CROSS(DX,MA(DX,2));
DRAWTEXT(FILTER(买=1,5),LOW,'★买一'),COLORRED;
加1:=MA18>=REF(MA18,3) AND CROSS(CLOSE,MA18);
DRAWTEXT(加1,LOW*0.99,'★加一'),COLORCC66FF;
卖一:=HHV(DX,2)=HHV(DX,7) AND COUNT(DX>50,2) AND CROSS(MA(DX,2),DX);
DRAWTEXT(FILTER(卖一=1,1),HIGH*1.01,'★卖一'),COLORGREEN;
{牛熊通吃}
AA1:=AMOUNT/V;
BB1:=L<AA1*0.9;
CC1:=(C-REF(C,1))/REF(C,1)*100>1.2;
DD1:=L<MA(C,5)*0.921;
EE1:=V<MA(V,5)*1.5;
FF1:=BB1 AND CC1 AND DD1 AND EE1;
DRAWTEXT(FF1,LOW*0.99,'老鼠仓'),COLOR4080FF;
{预测明天}
XXS:=MA(LOW,5)*(1-5/100);
XXS1:=MA(HIGH,5)*(1+5/100);
均线:=C,COLORGREEN;
AAAA:=CLOSE/REF(CLOSE,3)<=0.85 AND CROSS(C,XXS) AND C>REF(C,1),LINETHICK0 ;
DRAWTEXT(AAAA,L*0.95,'下影买'),COLORRED;
BBAA:=CROSS(XXS1,C);
DRAWTEXT(CROSS(XXS1,C),H,'开盘逃'),COLORWHITE;
DDDD:=CROSS(C,XXS1);
DRAWTEXT(DDDD,H,'明日走'),COLORYELLOW;
AAA:=MA(LOW,5)*(1-5/100);
BBB:=(HHV(AAA,5)+LLV(AAA,5))/2;
DRAWTEXT(CROSS(BBB,L) AND BBB>REF(BBB,1),L*0.98,'←兄弟回头棍'),COLORWHITE;
{双棍指标}
DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
DRAWTEXT(REF(CROSS(DEA,DIF),1) AND CROSS(DIF,DEA),L*0.97,'←散户回头棍'),COLORMAGENTA;
{见好就收}
VSR2:=(CLOSE-LLV(LOW,20))/(HHV(HIGH,20)-LLV(LOW,20))*100;
VSR3:=SMA(VSR2,4,1);
VSR4:=SMA(VSR3,2,1);
DRAWTEXT(VSR4>82 AND VSR3>89,HHV(C,30)*1.02,'收'),COLORGREEN;
试试这个

Q3:“横有多长 竖有多高”之横盘突破K线秘籍

通过股市谚语或者他人的经验是股民认识市场的捷径,但关键在于两点,首先,股民必须要真正去分析这些经验内在的本质是什么,需要有一个自己研究的过程,才能够了解其适用的范围和条件,以及如何用于自己的操作,而不是说盲目地拿来就用,那样往往会自取其套。其次,股民需要对于股市基础的变化保值足够的敏感度,也就是我在《解套第一课》书中第一章所介绍的股市动态,这些因素一旦发生大的变革就会导致原有的市场经验发生变化,很多原本可以应用的成功经验很可能就会成为误区,甚至是陷阱。所以说,股市唯一不变的就是其总是在变化,股民想要一劳永逸是不可能的,所有的股市成功者都是与时俱进的。 之前解套课堂,玉名给大家分析了“别人贪婪我恐慌,别人恐慌我贪婪”和“地量地价”,今天继续分析“横有多长,竖有多高”。这则谚语对于很多老股民来说会有很多甜蜜的回忆,但对如今很多新股民来说则是苦涩的。因为这则谚语是一条随着股市发展而变得过时了的谚语,我们按照刚刚的分析法则来解释下,股民便明白了。“横有多长,竖有多高”在于两个要素,一个是横,另一个就是竖,而横和竖又包括两点,起因和持续要素。先来说“横”,即为什么个股会处于横的状态,而处于这种状态后为什么会保持很长时间?之所以会横,很显然是市场环境处于熊市造成了个股表现受限,或者是个股本身出现了利空问题而走弱;并且这样因素迟迟没有解决,所以才会出现了长时间的横盘状态。所以说“横”传递出来的要点就是必须要先承认个股处于弱势和调整状态,个股出现了问题,那么我们就能够引出来“竖”的要点就是横的要素发生了根本变革,诱发资金介入从而带来了个股由弱转强,而长时间的整理说明原来弱势的要素很顽固,如今能够改变,必然是大利好,那么就会引入大量资金,自然个股就会呈现爆发式的增长。因此,股民要想得到这个“竖”,就必须要找到这个大利好,要么是市场环境的由熊转牛,要么就是个股利空要素的解决。 而之所以这则谚语在之前的A股市场非常管用,就是源于当时市场首先处于一个单向做多的环境下,并且股市的规模效小,且个股少,所以往往是齐涨共跌的状态,稍微大一些的资金可以主导市场趋势和个股行情;而股市也长时间处于暴涨暴跌的状态,资金进来就大涨,资金出去就大跌,所以一旦遇到熊市,成交量马上就萎缩到非常低的状态,导致个股大面积就处于横盘状态,而一旦进入到牛市,大量资金就涌入股市,而由于可选择的个股数量很少,资金会轮番介入个股炒作,哪怕是垃圾股也会轮到机会。并且由于股市只能够做多才赚钱,所以长期弱势格局后,资金对于做多的欲望会非常强烈,所以就会出现横有多长,竖有多高。 但自从2006年之后,A股发生了一系列的变化,首先是市场规模大幅扩张,然后资金渠道也在增加,这样直接带来了市场的变革,最直接的就是我们看到了市场规模扩大后的成交量激增,这说明市场需要驱动行情需要消耗更多的资金。其次是全流通进程,带来了大量的流通市值出现,而流通市值意味着炒作成本,换句话说,大小非解禁导致市场原有资金的话语权大大降低,最典型的就是基金,基金在2007年市场话语权超过3成,而2011年时只剩下了不到1成,这说明再大的资金面对快速扩张的A股来说都只是一个散户了,无法完全掌控市场趋势和个股行情,只能够顺势去做局部行情。接着,2010年又出现了股指期货,这意味着资金不再需要单纯做多的方式,而是立体化的赢利模式,即可做多、做空,还可以利用各品种间的套利模式来获利,彻底摆脱了原有资金与个股单向的模式,而是资金、个股、ETF、融资融券、股指期货和其他任何金融衍生品间的立体化模式。 所以我们看到了,A股正在向成熟市场靠拢,也出现了类似成熟市场的现象,那就是大量个股被边缘化,长期处于低迷的状态,而即便是在牛市中,也仅仅是主线个股出现持续大涨和明显的赚钱效应,而其余个股更多地是跟风和滞涨,一旦市场走弱就会继续调整。这还是在A股市场退市机制并不完善的情况,如果真的类似欧美市场那样严格的退市机制,很多长年横盘的个股就会启动退出机制,而资金也不会去碰这些品种,而是总去选择那些优质的品种炒作,这样一来,“横有多长,竖有多高”出现的条件变得越来越苛刻,越来越难,更多的时候,是个股横有多长就是多长,并不意味着其后面就会涨。想了解个股盘后点评,股市个股每日简评供您检索参考,股市机密内参(早盘、收盘、晚间三次更新),研究为您操作个股提供工具。博文是我的思路和观点,难免有些不合适您口味,投资就是个性化的事情,见仁见智,博客是我记录点滴感悟,以及和大家交流、探讨的地方,希望大家从文章中各取所需吧。无论文章观点如何,博您一笑一乐也是好的。

Q4:请高手帮忙编写通达信横盘整理突破公式。

N:=60;
EE:=(HHV(C,N)-LLV(C,N))/LLV(C,N);
BB:=REF(EE,1)<=0.2;
CC:=C>O AND C>=REF(HHV(C,N),1);
DD:=(C-REF(C,1))/REF(C,1)>=0.03;
横盘突破:BB AND CC AND DD;

Q5:如何识别突破前的真横盘与假横盘

这个就是靠经验了啊,

Q6:通达信;低位长期横盘突破

M=150;
V1:=MA(VOL,5);
V2:=VOL/REF(V1,1)>2;
PZ1:=MA(CLOSE,M);
PZ2:=HHV(HIGH,M);
PZ3:=LLV(LOW,M);
PZ4:=(PZ2-PZ1)/PZ1;
PZ5:=(PZ1-PZ3)/PZ1;
PZ:=REF(PZ4,1)<0.5 AND REF(PZ5,1)<0.15;
TP1:HHV(HIGH,M);
TP:=HIGH=TP1;
V2 AND PZ AND TP